Network Diagram
Figure 1 Network diagram for port-based VLAN configuration
Network Requirements
l As shown in Figure 1, Switch A and Switch B connect to Host 1 and Server 1 of a department and Host 2 and Server 2 of another department.
l To isolate the communication between the two departments at Layer 2, assign Host 1 and Server 1 to VLAN 100 with the descriptive string being Dept1, and Host 2 and Server 2 to VLAN 200 with the descriptive string being Dept2.
l Configure VLAN interfaces for the two VLANs on Switch A for forwarding data from Host 1 to Server 2 at Layer 3.
Configuration Example
l Configuration on Switch A
#
vlan 100
description dept1
#
vlan 200
description dept2
#
interface Vlan-interface 100
ip address 192.168.1.1 255.255.255.0
#
interface Vlan-interface 200
ip address 192.168.2.1 255.255.255.0
#
interface GigabitEthernet1/0/1
port access vlan 100
#
interface GigabitEthernet1/0/2
port link-type trunk
port trunk permit vlan 1 100 200
l Configuration on Switch B
#
vlan 100
description dept1
#
vlan 200
description dept2
#
interface GigabitEthernet1/0/10
port link-type trunk
port trunk permit vlan 1 100 200
#
interface GigabitEthernet1/0/11
port access vlan 200
#
interface GigabitEthernet1/0/12
port access vlan 200
#
interface GigabitEthernet1/0/13
port access vlan 100
Comments